Monday, 29 May 2017

Magneto Recharger / Remagnetiser for flywheel magnetos.

Much to my chagrin, the Ner-a-Car has not actually run since I took it on a trip to France. I have occasionally had an idea, tried it (replacing the capacitor with a modern one, for example) failed to make the bike run, and given up.
With a vintage vehicle day at work, and the Banbury Run looming in the near future I decided it was time to consider the bike again.
The spark seems very weak, and it wasn't all that weak before, so I wondered if perhaps the magnets had lost their magnetism. There isn't really much reason for them to, and I had them re-magnetised during the rebuild, but I speculated that perhaps the bike had been parked for a long time without the magneto armature being in the right place to act as a keeper. (it's a 2-stroke single, there are not many things that are capable of stopping it working).

Lots of people have build magneto chargers before, but nearly always for the usual horseshoe-shaped magnets that are found round the outside of the typical unit magnetos. The Ner-a-Car has the magneto magnets as part of the flywheel, which apart from anything else means that the magnetiser needs a bigger than normal span.
Initially I was planning to make a magnetiser almost exactly the same shape as the magneto armature, but after thinking it through I decided that a conventional layout would work, and would be adaptable for other types.

It seems to be agreed that you need 20,000 Ampere-turns to remagnetise a magneto. I did some calculations in Excel during my lunch-hour. I attempted to optimise for the minimum mass of wire.
I figured out some numbers and bought 1kg of 1mm wire and then waited for it to arrive. I then realised that I had made an error in my calculations, and had been under-estimating resistance by a factor of 10. This meant that my 20A 240V coil would actually be a 200A coil, and that seemed like a bad idea.
So, I had a bit of a re-think and decided that I would use 2 x 12V coils in parallel. These would take 60A, but anyone with a vehicle that doesn't rely on a magneto and generator has a suitable supply in the form of the battery.

So, I ordered 1kg of 1.4 mm (diameter) wire.
The coil formers are 25.4mm mild steel bars, machined to a length of 86.5mm with 5mm plastic end-caps pressed on. The windings are 7 layers of wire @ 50 turns per layer for a total of 350 turns per coil. 30A through each coil is 21,000 Ampere-Turns.
The coils are linked and mounted by a mild-steel bar, 35 x 20mm. I made some top pieces out of the remainder and the thing is assembled with M8 screws.

When I wound the magneto itself there were 20,000 turns to wind, and I did it on the lathe under power. However this wire was a lot stiffer, and was going to need more attention to persuade it to lie straight, so I mounted the bars on a threaded stub in the chuck of my Rivett lathe, and mounted a winding handle on the other end. Then I wound the coils by hand with the lathe drive disconnected.

The wire terminates at 1/4" copper tags fitted into slots machined in the end-caps and secured by an M2 countersunk screw. One end of the wire was filed clean of varnish and tinned, then soldered to the tag. Then the assembly was carried down to the lathe, mounted and wound. At the end of layer 7 the wire was cut, tinned and soldered to the other terminal tag.

I didn't take any photos of the construction. In fact I didn't take any photos until I had finished.

Once assembled I used a small current-limited PSU to identify the N and S poles, using a device that I got from eBay.  testing with my magneto (which has a clearly stamped "N" on one pole I was able to determine that with my pole finder the red end points to N.

Something that hadn't been 100% clear to me prior to building this device is that when magnetising a magneto the N of the magneto magnet sits on the S of the charger. (which I think is somewhat the reverse of the situation with a battery charger)





The magneto is simply placed on top of the charger and the other ends of the wires held against the battery terminals for a few seconds. The coils became warm but not hot in that time-scale. 


Did it work? I am not 100% sure. But I did get to ride the bike round the block early this afternoon. 




Tuesday, 23 May 2017

Harmonic Drive 4th Axis

I have already made a 4th axis for my cnc-converted Harrison Milling machine. It is a servo-driven BS0 dividing head. It works OK but lacks the torque for 4th-axis milling and it is impossible to have the backlash low enough in the sloppy bits without the servo stalling in the tight bits. It still makes gears relatively OK, but you can almost forget rotary-axis engraving.

I found out that Harmonic Drive make some really nice integrated drive/bearing/servo assemblies that are pretty much a 4th-axis waiting to happen. Lots of torque capacity, a large crossed-roller bearing and an integrated servo drive with a hollow shaft for through-spindle work. All very nice, and extremely expensive new. They are even expensive on eBay, but if you set up a watch you can occasionally find a bargain. I was in no hurry, and eventually picked one up for $250 from a seller in the US. It wasn't quite that simple, I had to get it shipped to a friend in Richmond, CA, then he stripped off a huge and heavy bracket and sent it on the slow (and cheap) boat to me. I ended up paying both California VAT and UK VAT on it, but it still saved a few $100 on the original quoted shipping price.

The drive I got was an older FHA-25B drive. This turned out to be a happy accident, as the FHA-xxB drives use Hall sensors for commutation and conventional quadrature encoders. The later FHA-xxC drives use a proprietary serial encoder for feedback and commutation, and only really work with the dedicated drives. If you choose to follow this route, look for the B-series actuators. 

The harmonic drive is pretty-much ready to go as-is, it just needs a bracket. I decided to use cast iron.
I designed a bracket in Inventor, and then used the excellent CAM in Fusion 360 to machine a pattern.



Machining took quite some time. I used a some pre-used SikaBlock M970 that I had lying about. In the process I made quite a mound of pretty green petals. 


And then at the end had a fairly good pattern in the wrong colour to send to the iron foundry.


One thing that I decided early on about this 4th-axis is that it would use the same spindle-nose as my lathe, so that I can use the chucks, face-plates and collet adaptors that fit that, and potentially transfer work directly from one to the other. A not unimportant consideration here is just how tedious it is to centre work in the 4-jaw chuck in a dividing head. Even a CNC one is tedious, I hate to imagine what it would be like twiddling a handle. 

My lathe is a D1-4 nose so I set about making that while waiting for the foundry. I used some EN24 / 817M40 (having bought half a pallet of bar-ends on eBay). The D1-4 nose has 3 locking cams (the D1-5 to D1-20 have 6). This leads to some difficulty as the harmonic drive has 8 mounting holes round the register and this was a bad fit to the 3-fold symmetry of the spindle nose. It took a bit of fiddling in CAD but by deciding to retain the locking cams in an unconventional way (there are no centrifugal forces to counteract) I managed to find a way to squeeze in 5 mounting screws. I also did a CAD investigation of how to manage a D1-5, but that ended up with a two-piece nose with mounting bolts buried inside. 


First I bored out a recess to match the register on the dividing head. 



Then I drilled and deeply countersunk the mounting-bolt holes on the mill. At the same time I drilled and finish-bored the holes that take the three camlock locking studs. 

I then machined a dummy register to match that on the harmonic drive, mounted the nose on that, and completed the machining. 


A trial fit on the harmonic drive proved that I hadn't messed up my units or something silly.


There was then something of a hiatus waiting for the castings. During this time I was looking around for a suitable drive. I got in touch with the chaps from the STMBL project  who have an open-source drive almost ideal for the actuator (it is a 200V class servo, I will probably be running it on rectified UK mains). Luckily one of them was due to visit London Hackspace the next week, so I popped in too, with a few motors, including the harmonic drive, and was lucky enough to go home with a beta-sample of the V4.0 drive 

Eventually the castings came back. I had 4 cast. One for me, one spare, and two for two other folk who expressed an interest. They came in at £60 each. 




 The first job was to square them off, removing the casting draught and making a couple of reference faces. This is something that my Univeral Mill is pretty good at in horizontal mode.

First the base to the as-cast front face (the mould parting face, to pretty flat)


Then the front face square to the base. 



For making the bore/seat for the harmonic drive I needed to ensure that the bore was true to the front reference face, so I squared the part on the mill with a dial indicator for perpendicular.
I then had to decide where in the casting the centre of the hole was. This was, of necessity a rather approximate process as the hole was not round, and the surface not smooth. But I minimised the blur on my  coaxial indicator and bored through with my automatic boring head:


The other diameters are bigger, so I had to make a rather Heath Robinson setup with one of the extension bars to enable back-boring. This looked a bit implausible, but actually worked surprisingly well. 

Once the bores were done, I could drill and tap the mounting holes. This could have been done from the chuck-side with through-holes, but I decided to do it the hard way, which required the purchase of a long-series drill and the manufacture of a tap extension:


The only thing remaining was to machine the location grooves in the base to align the head with the table slots. This was actually a problem that exercised my imagination, as the slots need to be exactly aligned under the mounting bore. Here is what I did, I would be interested in other ideas. 

First, I trued the base of the casting to the X axis of the mill:


Then picked up the middle of the bore with my coaxial indicator in the vertical head. 


I then made a reference slot with a 5mm cutter in an area that would be removed by the alignment key slot. This was made to fit a piece of brass with a hole bored as exactly as I could manage in the middle. 


I then switched to the horizontal head and picked up the hole in the piece of brass with my coaxial indicator. I thus found that the axes of my horizontal and vertical spindles are not absolutely exactly coincident, there seems to be a 0.15mm offset. Or I made a 0.15mm error in my work...


Alignment slots and cut, a coat of paint, and the mechanical work is done, time now to figure out the drivers and HAL connections. Once that is done I can bore the holes for the camlock cams. these are specified at a specific angle from the camlock stud holes, so it makes sense to wait until the head is powered to machine those.